Welcome to Mersey Modified
The only home for all types of motor enthusiasts in Merseyside and the surrounding areas.
Welcoming Classic, American and Modified, motors. As well as motorcycles and scooters.
Please take the time to register with our site and introduce yourself in the 'Newbies' section.
We only ask that you respect other members, keep your posts non-confrontational, positive and try to keep any personal issues off the forum.

Many Thanks
Mersey Modified Staff

    AMP please

    Share
    avatar
    Fonzi

    Posts : 919
    Join date : 2010-10-21
    Age : 31
    Location : Manchester / Warrington

    AMP please

    Post  Fonzi on Thu Apr 19, 2012 7:29 am

    Hi guys

    Got an edge sub of a lad from work tuva day an the active amp it had is missing somehow so im after a amp i can screw onto it.

    anyone got one?

    cheers


    _________________


    I REACH FOR THE SKY
    IVE SAID MY GOODBYES
    MY HEARTS ALWAYS WITH YOU NOW
    R.I.P DARREN
    NEVER FORGOTTEN
    avatar
    CustomIce

    Posts : 17
    Join date : 2011-03-17
    Location : Bromborough

    Re: AMP please

    Post  CustomIce on Fri Apr 20, 2012 4:06 am

    Have a look at halfords they have a clearance offer on at the mo, select stores. might get lucky.

    Depending on the box design you may need to blank off and seal where the other amp lived unless it was sealed into it's own little section.

    http://www.halfords.com/webapp/wcs/stores/servlet/product_storeId_10001_catalogId_10151_categoryId_237503_productId_184579_langId_-1?cm_mmc=Criteo-_-Category-_-Product-_-Na&_$ja=tsid:35814

    or Fli (Ormskirk has some)

    http://www.halfords.com/webapp/wcs/stores/servlet/product_storeId_10001_catalogId_10151_productId_504657_categoryId_237503_langId_-1?cm_sp=Intelligent_Offer-_-Product_Details_Zone_1-_-Blank&iozone=PDPz1


    Last edited by CustomIce on Fri Apr 20, 2012 4:09 am; edited 1 time in total (Reason for editing : added links)
    avatar
    Fonzi

    Posts : 919
    Join date : 2010-10-21
    Age : 31
    Location : Manchester / Warrington

    Re: AMP please

    Post  Fonzi on Fri Apr 20, 2012 4:43 am

    Would both of these work with an edge sub? like i said got it off me mate for free an the active sub that was attached is missing. How would i go about wiring one in if i got it. PLus none seem to be near me Sad


    _________________


    I REACH FOR THE SKY
    IVE SAID MY GOODBYES
    MY HEARTS ALWAYS WITH YOU NOW
    R.I.P DARREN
    NEVER FORGOTTEN
    avatar
    CustomIce

    Posts : 17
    Join date : 2011-03-17
    Location : Bromborough

    Re: AMP please

    Post  CustomIce on Fri Apr 20, 2012 4:55 am

    What you'd need to di is get a bit of speaker wire and attach it to the sub's terminals, you may need to unscrew it to get at them. run this throught the enclosure and out the back, ideally through an airtight gromet or set of dual speaker terminals (i have some here)

    If there is anything else connected to the sub, disconnect it, as you won't need it.

    You next need a power and signal wiring kit and hook this p to the amp as normal.

    The Alpine amp will run in single channekl or bridged mode and this is what you're looking for, so wire up as in the manual (usually across the dual speaker outputs. and set the filters for low pass and you should be good to go.



    avatar
    Fonzi

    Posts : 919
    Join date : 2010-10-21
    Age : 31
    Location : Manchester / Warrington

    Re: AMP please

    Post  Fonzi on Fri Apr 20, 2012 4:57 am

    would the fli one do it as that only 18 mile from me - the a;pine oneson in newscastle 116 mile away lol.

    its an edge ebd190 active enclosure sub. just missing the amp obv.

    so just get a noraml wiring kit?


    _________________


    I REACH FOR THE SKY
    IVE SAID MY GOODBYES
    MY HEARTS ALWAYS WITH YOU NOW
    R.I.P DARREN
    NEVER FORGOTTEN
    avatar
    CustomIce

    Posts : 17
    Join date : 2011-03-17
    Location : Bromborough

    Re: AMP please

    Post  CustomIce on Fri Apr 20, 2012 5:04 am

    Looks like it will run bridged.

    http://issuu.com/talkaudio/docs/fli_loaded450s_manual

    and the reviews mention it being used to run subs, so most likely.
    avatar
    Fonzi

    Posts : 919
    Join date : 2010-10-21
    Age : 31
    Location : Manchester / Warrington

    Re: AMP please

    Post  Fonzi on Fri Apr 20, 2012 5:06 am

    Just go for that then?


    _________________


    I REACH FOR THE SKY
    IVE SAID MY GOODBYES
    MY HEARTS ALWAYS WITH YOU NOW
    R.I.P DARREN
    NEVER FORGOTTEN
    avatar
    CustomIce

    Posts : 17
    Join date : 2011-03-17
    Location : Bromborough

    Re: AMP please

    Post  CustomIce on Fri Apr 20, 2012 5:07 am

    Up to you mate, at £17 the worst you'll end up with is an amp to run the front speakers with!

    The other option is to look for monoblock or 2/1 channel amps on fleabay
    avatar
    Fonzi

    Posts : 919
    Join date : 2010-10-21
    Age : 31
    Location : Manchester / Warrington

    Re: AMP please

    Post  Fonzi on Fri Apr 20, 2012 5:11 am

    cool

    cheers for all the help buddy.


    _________________


    I REACH FOR THE SKY
    IVE SAID MY GOODBYES
    MY HEARTS ALWAYS WITH YOU NOW
    R.I.P DARREN
    NEVER FORGOTTEN
    avatar
    CustomIce

    Posts : 17
    Join date : 2011-03-17
    Location : Bromborough

    Re: AMP please

    Post  CustomIce on Fri Apr 20, 2012 5:12 am

    My pleasure Fonzi. Good luck whatever you go for.
    avatar
    Fonzi

    Posts : 919
    Join date : 2010-10-21
    Age : 31
    Location : Manchester / Warrington

    Re: AMP please

    Post  Fonzi on Fri Apr 20, 2012 5:18 am

    gona go get it later after work an a standard wiring kit an prob blow meself up tomroow trying to fit it cause im useless haha


    _________________


    I REACH FOR THE SKY
    IVE SAID MY GOODBYES
    MY HEARTS ALWAYS WITH YOU NOW
    R.I.P DARREN
    NEVER FORGOTTEN
    avatar
    CustomIce

    Posts : 17
    Join date : 2011-03-17
    Location : Bromborough

    Re: AMP please

    Post  CustomIce on Fri Apr 20, 2012 5:23 am

    Just make sure nothing is shorted out (speaker wires or power, straggly bits of copper wire touching the wrong terminal)

    You may have to get some crimp connections for the speaker terminal or solder it on the sub.

    Run all you cable in first and leave the fuse out until last.

    Good ground point in the boot is critical to the whole thing working, this includes a secure bolted point and bare metal, and don't forget the remote wire to the headunit or a 12v switched feed.

    just take your time and if it looks dodgy double and triple check it's right, and then ask.

    Remember there is serious risk when using high current cabling of causing fire, so just don't do it unless you're sure you know what you're doing.
    avatar
    Fonzi

    Posts : 919
    Join date : 2010-10-21
    Age : 31
    Location : Manchester / Warrington

    Re: AMP please

    Post  Fonzi on Fri Apr 20, 2012 6:06 am

    Il give it a go. Before i even attached the power feed il wire the sub to the amp. then place it in the ca, run the cables the attach eveyrthing at the end.

    reserved an picking it up later Smile


    _________________


    I REACH FOR THE SKY
    IVE SAID MY GOODBYES
    MY HEARTS ALWAYS WITH YOU NOW
    R.I.P DARREN
    NEVER FORGOTTEN

    Sponsored content

    Re: AMP please

    Post  Sponsored content


      Current date/time is Sat Nov 17, 2018 11:16 am